Welcome to Simetrik's status page central
Explore real-time updates on the status of Simetrik's suite of products and services below.

[MEXICO] Authentication service Outage

Incident Report for Simetrik NCLC

Resolved

Service outage detected with Authentication service in MEXICO
Posted Apr 08, 2026 - 12:51 GMT-05:00

Investigating

Service outage detected with Authentication service in MEXICO
Posted Apr 08, 2026 - 12:42 GMT-05:00
This incident affected: Tenant Mexico (Authentication service).