Welcome to Simetrik's status page central
Explore real-time updates on the status of Simetrik's suite of products and services below.

[GLOBAL] Service Disruption in Dashboard Visual Downloads

Incident Report for Simetrik NCLC

Resolved

We have completed our monitoring and verified that all systems are operating normally. The issue with dashboard visual downloads is officially resolved.
Posted Mar 30, 2026 - 16:30 GMT-05:00

Monitoring

Dashboard visual downloads have been restored. We are currently monitoring the service to ensure continued stability.
Posted Mar 30, 2026 - 15:34 GMT-05:00

Investigating

We are currently investigating an issue affecting dashboard visual downloads. Our team is actively working on it, and we will provide more information on our status page shortly
Posted Mar 30, 2026 - 15:16 GMT-05:00
This incident affected: Tenant Global (Download service).