The incident has been resolved, and service has been fully restored.
Following the deployment of the fix, we completed a monitoring period and confirmed the stability of the solution. Dashboard access and functionality are operating normally.
We apologize for the inconvenience caused and appreciate your patience throughout this incident.
Posted Jul 23, 2026 - 12:49 GMT-05:00
Monitoring
A fix has been implemented, and the affected services have recovered. Dashboard access and functionality have been restored.
We are currently monitoring the platform to ensure stability and confirm that the issue has been fully resolved.
Posted Jul 23, 2026 - 11:43 GMT-05:00
Identified
We are currently experiencing a service degradation affecting access to dashboards. Some customers may experience intermittent issues when opening their dashboards, including dashboards remaining in a loading state or failing to display results.
Our engineering team is actively investigating the issue and working to restore normal service as quickly as possible.
We apologize for the inconvenience and will provide further updates as more information becomes available.
Posted Jul 23, 2026 - 11:30 GMT-05:00
This incident affected: Tenant Global (Data Analysis WEB application).