Welcome to Simetrik's status page central
Explore real-time updates on the status of Simetrik's suite of products and services below.

[GLOBAL] Accounting Translator API service Outage

Incident Report for Simetrik NCLC

Resolved

Service outage detected with Accounting Translator API service in GLOBAL
Posted Nov 27, 2025 - 16:24 GMT-05:00

Investigating

Service outage detected with Accounting Translator API service in GLOBAL
Posted Nov 27, 2025 - 16:14 GMT-05:00
This incident affected: Tenant Global (Accounting Translator API service).